Yoko

All sides of Injection
It is currently 2018-08-16 03:55:05

All times are UTC+02:00




Post new topic  Reply to topic  [ 16 posts ] 
Author Message
PostPosted: 2016-10-26 01:01:49 
Offline

Joined: 2016-10-26 00:54:05
Posts: 6
Добрый день, ув. форумчане,
Вы единственная и последняя надежда на решение проблемы - не получается запустить Inject на MacOS.
Установил Ultima Online используя Wine 1.8.5, сама игра - запускается.
Затем скачал Inject 1508.09, выдает мне ошибку "Patch Error".
Пытался установить более старые версии Inject'a, там выдавал ошибку "ilpatch.cfg error", но я менял вручную ilpatch.cfg и добавлял клиент, пробовал добавить так же клиент через ylaunch.exe - результатов 0.
Пробовал кучу всяких разных клиентов и стандартные и которые с более высоким разрешением.

Помогите пожалуйста.
Спасибо.


Top
   
PostPosted: 2016-10-26 08:32:56 
Offline
User avatar

Joined: 2009-05-28 09:58:28
Posts: 2778
Location: Иваново
Мака под рукой нет но я пользовался wine на ubuntu. Сомневаюсь что сильно отличаются настройки.
Я делал в wine папку с указанием на неё виртуального диска D:\ туда заливал клиент игры, и при запуске инжекта указывал "Windows"-ные настройки - d:\games\ultima
Если клиент старый то надо запустить reg файл (если у вас его нет то могу скинуть). Если старше 5 то вроде запускался и так.

ЗЫ постараюсь сегодня поднять виртуалку с убунтой и повторить. Если будут какие то тонкости отпишусь.

PS лучше использовать последную версию инжекта. На старой с шифрованием замучаешься.

_________________
Image
YokoInjection CodeSweeper
Ошибка "Unhandled exception in parser"


Top
   
PostPosted: 2016-10-26 11:56:55 
Offline
User avatar

Joined: 2013-05-28 13:13:02
Posts: 148
Тонкостей нет. Уже 10 лет сижу на ВАЙНе:)
Да, нужно проверить конфиг вайна.
Клиент без инжекта запускается нормально?
Скинь скрины конфигурации вайна и ilaunch

_________________
Русский Сервер Ultima Online High Seas Adventures
Legendary


Top
   
PostPosted: 2016-10-26 13:07:51 
Offline

Joined: 2016-10-26 00:54:05
Posts: 6
RL_ka wrote:
Тонкостей нет. Уже 10 лет сижу на ВАЙНе:)
Да, нужно проверить конфиг вайна.
Клиент без инжекта запускается нормально?
Скинь скрины конфигурации вайна и ilaunch


wine конфиг файлы - это system.reg, user.reg, userdef.reg?
У меня просто на MacOS все через homebrew (package manager) устанавливается и конфигурируется по дефолту.
В новом Inject нет ilaunch.cfg.
Мог бы ты меня добавить в скайпе (davidovs_olegs)? Я тебе там все скинул бы..


Top
   
PostPosted: 2016-10-26 13:24:17 
Offline
User avatar

Joined: 2013-05-28 13:13:02
Posts: 148
У вайна есть утилита, которая называется Wine configuration. В ней есть вкладка Drives, вот её скриншот нужно.
ilaunch.cfg мне тоже не нужен, нужен хотя бы скриншот самого запущенного ilaunch чтобы увидеть настройки.

_________________
Русский Сервер Ultima Online High Seas Adventures
Legendary


Top
   
PostPosted: 2016-10-26 13:44:41 
Offline

Joined: 2016-10-26 00:54:05
Posts: 6
RL_ka wrote:
У вайна есть утилита, которая называется Wine configuration. В ней есть вкладка Drives, вот её скриншот нужно.
ilaunch.cfg мне тоже не нужен, нужен хотя бы скриншот самого запущенного ilaunch чтобы увидеть настройки.


В MacOS я так понимаю нет Vine configuration :(


Attachments:
Screen Shot 2016-10-26 at 14.43.54.png
Screen Shot 2016-10-26 at 14.43.54.png [ 143.08 KiB | Viewed 1551 times ]
Top
   
PostPosted: 2016-10-26 14:10:33 
Offline

Joined: 2016-10-26 00:54:05
Posts: 6
Может быть реально каких то драйверов не хватает? Я вроде пытался найти requirements для Inject'a, но ничего не нашел ;(


Top
   
PostPosted: 2016-10-26 14:34:53 
Offline
User avatar

Joined: 2013-05-28 13:13:02
Posts: 148
Сайт вайна утверждает что конфигуратор всё-таки есть
пункт 3
https://wiki.winehq.org/MacOSX_FAQ

_________________
Русский Сервер Ultima Online High Seas Adventures
Legendary


Top
   
PostPosted: 2016-10-26 14:36:57 
Offline

Joined: 2016-10-26 00:54:05
Posts: 6
Да, ты прав.. не заметил :)
p.s. сам клиент запускается, значит должно быть все ок с настройками.


Attachments:
Screen Shot 2016-10-26 at 15.36.31.png
Screen Shot 2016-10-26 at 15.36.31.png [ 29.57 KiB | Viewed 1547 times ]
Top
   
PostPosted: 2016-10-27 21:11:21 
Offline

Joined: 2016-10-26 00:54:05
Posts: 6
По прежнему нужна помощь ;(


Top
   
PostPosted: 2016-10-31 20:09:53 
Offline
User avatar

Joined: 2009-05-28 09:58:28
Posts: 2778
Location: Иваново
После установки ubuntu 16 консолькой поставил wine
Диск D:\ в конфиге указываешь либо на папку либо на физический hdd
Папка с игрой и инжектом находилась на NTFS диске в папке games\uoml\yoko
Запустил Launcher.exe. В настройках ничего не менял после запуска игры с windows
Attachment:
Снимок экрана от 2016-10-31 21-01-57.png
Снимок экрана от 2016-10-31 21-01-57.png [ 8.51 KiB | Viewed 1496 times ]

Сразу вошел в игру.


Для 2.0.3 клиента пришлось чуть постучать в бубен.
В консоли набираем wine regedit
запускается реестр венды изподвайна. Вверху кнопка Реестр - Импорт файла реестр.
и загружаем файл uo.reg следующего содержания:

Quote:
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online\Ultima Online]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online\Ultima Online\1.0]
"ExePath"="D:\\Games\\Ultima\\client.exe"
"InstCDPath"="D:\\"
"StartExePath"="D:\\Games\\Ultima\\uo.exe"
"PatchExePath"="D:\\Games\\Ultima\\uopatch.exe"
"Upgraded"="Yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online\Ultima Online\1.0\HWProfile]
"processorType"=hex:03
"processorClock"=hex:01,b2
"nProcessors"=hex:01
"szVideoCardDescrip1"=""
"szVideoCardDescrip2"=""
"timeZoneBias"=hex:4c,77,f8,77

D:\\Games\\Ultima\\client.exe
Путь до клиента 2.0.3. Путь может быть другим но двойные слеши обязательны.
После закрываем реестр и запускаем Launcher.exe. Игра запустится с инжектом.

_________________
Image
YokoInjection CodeSweeper
Ошибка "Unhandled exception in parser"


Top
   
PostPosted: 2017-12-29 14:20:51 
Offline

Joined: 2010-03-19 18:40:48
Posts: 13
Mirage wrote:
После установки ubuntu 16 консолькой поставил wine
Диск D:\ в конфиге указываешь либо на папку либо на физический hdd
Папка с игрой и инжектом находилась на NTFS диске в папке games\uoml\yoko
Запустил Launcher.exe. В настройках ничего не менял после запуска игры с windows
Снимок экрана от 2016-10-31 21-01-57.png
Сразу вошел в игру.


Для 2.0.3 клиента пришлось чуть постучать в бубен.
В консоли набираем wine regedit
запускается реестр венды изподвайна. Вверху кнопка Реестр - Импорт файла реестр.
и загружаем файл uo.reg следующего содержания:

Quote:
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online\Ultima Online]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online\Ultima Online\1.0]
"ExePath"="D:\\Games\\Ultima\\client.exe"
"InstCDPath"="D:\\"
"StartExePath"="D:\\Games\\Ultima\\uo.exe"
"PatchExePath"="D:\\Games\\Ultima\\uopatch.exe"
"Upgraded"="Yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Origin Worlds Online\Ultima Online\1.0\HWProfile]
"processorType"=hex:03
"processorClock"=hex:01,b2
"nProcessors"=hex:01
"szVideoCardDescrip1"=""
"szVideoCardDescrip2"=""
"timeZoneBias"=hex:4c,77,f8,77

D:\\Games\\Ultima\\client.exe
Путь до клиента 2.0.3. Путь может быть другим но двойные слеши обязательны.
После закрываем реестр и запускаем Launcher.exe. Игра запустится с инжектом.

мне не помогло( всё та же ошибка cannot open fonts.mul


Top
   
PostPosted: 2017-12-29 22:46:21 
Offline

Joined: 2010-03-19 18:40:48
Posts: 13
получилось запустить из под инжекта но при входе в игру черный экран(


Top
   
PostPosted: 2017-12-31 13:35:45 
Offline
User avatar

Joined: 2009-05-28 09:58:28
Posts: 2778
Location: Иваново
не помогло потому что реестр криво прописал. В черный экран либо путь не тот либо не обновленны какие то библиотеки. Ты систему до актульной версии обновил? Ну и норм было бы то бы все таки указал версию или хотя бы тип операционки. А то так то я ман писал для бубунты а ты может с андроида дрюнькаешь.

_________________
Image
YokoInjection CodeSweeper
Ошибка "Unhandled exception in parser"


Top
   
PostPosted: 2018-01-02 22:12:18 
Offline

Joined: 2010-03-19 18:40:48
Posts: 13
Mirage wrote:
не помогло потому что реестр криво прописал. В черный экран либо путь не тот либо не обновленны какие то библиотеки. Ты систему до актульной версии обновил? Ну и норм было бы то бы все таки указал версию или хотя бы тип операционки. А то так то я ман писал для бубунты а ты может с андроида дрюнькаешь.


1.Получается зайти на голом клиенте через обертку wineskin, ежели через сам клиент то пишет fonts.mul
2.через последнюю версию 1508,09 инжекта не получается зайти вылетает ошибка тоесть инжект открывается, потом проходишь авторизацию и когда заходишь в саму игру то черный (на скрине белый) экран который висит и закрыть его можно только принудительно https://ibb.co/bu5v1b https://ibb.co/g9uoMb https://ibb.co/n1kv1b https://ibb.co/djezSG еще бывает вот такая ошибка это когда только клиент открылся (а инжект не открылся) https://ibb.co/g1uinG
3.Если заменяю дллку инжекта на версию 1403.16 то при первом открытии вылетает ошибка https://ibb.co/g1uinG а со второй попытки заходит нормально, но а)размер экрана не регулируется через настройки инжекта б)присутствует большая задершка курсора мыши в)В игре присутствуют лаги. Через другие версии инжекта пока что не пробовал. https://ibb.co/iG7jcG
Операционная система -mac os high sierra 10.13.2
Клиент версия - 7.0.23.1 (patch 65)
wine - 1.7.0
wineapp 1.1


Top
   
PostPosted: 2018-01-09 23:15:09 
Offline
User avatar

Joined: 2009-05-28 09:58:28
Posts: 2778
Location: Иваново
Так и пришлось на виртуалке поднимать macos 10.13 :)
Честно говоря не очень понимаю с чем могут быть трудности.
Клиент в папке на рабочем столе (любой другой папке).
Заходим на сайт wine и скачиваем последнюю стабильную версию (wine-2.0.4).
Правым кликом по файлу Launcher.exe и выбираем запускать с помощью стабильного важна.
Далее указываешь путь до каталога клиента и самого клиента.
6.10 и 7.18 клиенты завелись без каких либо дополнительных настроек. Все что было настроено в винде включая хоткеи и десктопные значки благополучно мигрировали на мак.

В общем юзайте стабильные релизы и не торопитесь.

ЗЫ после тыкания первый раз в любой exe файл вайн сам подтянет необходимые библиотеки. Для запуска инжекта этого вполне достаточно.

ЗЗЫ возможно какие то не правильные галки выставлены в инжекте в секции конекшен и main

_________________
Image
YokoInjection CodeSweeper
Ошибка "Unhandled exception in parser"


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 16 posts ] 

All times are UTC+02:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited